AC旁挂核心配置(AC-核心)

一、需求:

    AP地址池在核心上 10.10.10.1/24 网关:10.10.10.254/24 vlan10
    无线用户地址池在核心上 192.18.0.1/24 网关:192.18.0.254/24 vlan20

AC配置

1
---AP上线配置---
2
3
Ruijie>enable
4
//进入特权模式
5
6
Ruijie#configure terminal
7
//进入全局配置模式
8
9
Ruijie(config)#int loopback 0
10
Ruijie(config-if-Loopback 0)#ip address 1.1.1.1/24
11
Ruijie(config-if-Loopback 0)#exit
12
//配置该ip地址用于与AP建立capwap隧道
13
14
Ruijie(config)#int vlan10
15
Ruijie(config-int-vlan)#ip add 10.10.10.1/24
16
Ruijie(config-int-vlan)#exit
17
//创建与核心互联vlan
18
19
Ruijie(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.254
20
//配置全局路由指向核心vlan10地址
21
22
Ruijie(config)#int gigabitEthernet 0/8
23
//AC和核心互连端口trunk配置
24
25
Ruijie(config-if-GigabitEthernet 0/8)#switchport mode trunk
26
//进入到g0/8口(与核心互联端口)
27
28
Ruijie(config-if-GigabitEthernet 0/8)#exit
29
//将该接口配置成trunk端口
30
31
Ruijie(config)#end
32
//结束配置
33
34
Ruijie#wr
35
//保存配置
Copied!

核心上配置:

1
AP网关和dhcp配置
2
3
Ruijie(config)#vlan 10
4
//创建ap管理vlan 10
5
6
Ruijie(config-vlan)#exit
7
Ruijie(config)#interface vlan 10
8
Ruijie(config-int-vlan)#ip add 10.10.10.254/24
9
Ruijie(config-int-vlan)#exit
10
//该地址做为ap的网关地址
11
12
Ruijie(config)#service dhcp
13
//开启DHCP服务
14
15
Ruijie(config)#ip dhcp pool ap_ruijie
16
//创建AP设备DHCP地址池,名称是ap_ruijie
17
18
Ruijie(config-dhcp)#option 138 ip 1.1.1.1
19
//配置option字段,指定AC的地址,即AC的loopback 0地址
20
21
Ruijie(config-dhcp)#network 10.10.10.0/24
22
//分配给ap的地址
23
24
Ruijie(config-dhcp)#default-route 10.10.10.254
25
//分配给ap的网关地址
26
27
Ruijie(config-dhcp)#exit
28
//退出DHCP配置
29
30
Ruijie(config)#ip route 1.1.1.1 255.255.255.255 10.10.10.1
31
//配置option路由指向AC网关
32
33
Ruijie(config)#ip dhcp pool ap_wifi
34
//创建wifi用户DHCP地址池,名称是ap_wifi
35
36
Ruijie(config-dhcp)#network 192.18.0.0/24
37
//分配给wifi用户的地址
38
39
Ruijie(config-dhcp)#default-route 192.18.0.254
40
//分配给wifi用户的网关地址
41
42
Ruijie(config-dhcp)#exit
43
//退出DHCP配置
44
45
Ruijie(config)#interface range g0/1-24
46
Ruijie(config-if-range)#switchport mode trunk
47
//配置下联AP/接入交换机端口
48
49
Ruijie(config-if-range)#switchport trunk native vlan 10
50
//注意:AP没有使用vlan1,则需要将对应的vlan改为native vlan(本征vlan)
51
52
Ruijie(config-if-range)#exit
53
//退出接口配置
54
55
Ruijie(config)#interface g0/1
56
Ruijie(config-if-GigabitEthernet 0/1)#switchport mode trunk
57
//核心和AC互连端口trunk配置
58
59
Ruijie(config-if-GigabitEthernet 0/1)#switchport trunk allowed vlan only 10,20
60
//vlan裁剪,放通所需vlan
61
62
Ruijie(config-if-GigabitEthernet 0/1)#exit
63
//退出接口配置
64
65
Ruijie(config)#end
66
//结束配置
67
68
Ruijie#wr
69
//保存配置
Copied!

检验:

    AP/PC能在核心/接入交换机上正常获取到 vlan10地址
Last modified 1yr ago
Copy link